Jump to content
Sign in to follow this  
ShelbyGT5HUN

2010 Gt500 Clutch Pedal Wants To Stick To Floor Under High Rpms

Recommended Posts

The Issue:

 

Normal shifting only. Not speed or no lift. Just shifting smoothly, but at high rpms.

 

Shifting at high rpms, between 4,500 and redline, the clutch will stick to the floor / lose its return force, just enough to almost lock you out of any upward gear changes. When shifting, it feels like you just might not get the next gear. This happens on the 1-2 shift, 2-3 shift, and 3-4 shift. Can't check the 4-5 shift, because I don't really want to be going that fast anyway.

 

I don't get any grinding of gears during the gear change, but when the rpms are high, it feels like I'm almost out of clutch fluid, and shifting becomes a guessing game. It feels to me through my left foot that there is too much "spinning force" or some kind of "suction", yes these are non-engineering terms, created by the high rpms that is keeping things from separating between the clutch pressure plate and friction disk. The clutch pedal just becomes really mushy and almost non-functional at the 4,500 to redline area on the tach. At lower RPMs, and in traffic, the clutch pedal, and transmission function 100% fine.

 

I have 7 months on the powertrain warranty, and this car has been BABIED since day one. No powershifting, no drag racing. The fact that the warranty is ending, has motivated me to drive the car harder than I have in the past to see what could be wrong with it. In fact, this problem was hard to discover, and I have only just noticed it, because you really can't test this anywhere except on the highway.

 

You are doing well over 120+ to bang out all those gears changes. Even a full bore 2-3 shift at redline is around 80mph! I am taking it to the dealer for a check, but I really expect nothing from them. In fact I don't want them to test it due to the speeds involved, and the thought of a tech romping on the car does not sit well with me. It seems like this problem will just be brushed under the rug. However, I cannot own a car that can't be driven within factory power levels. Yes I have a pulley, but come on, 14psi vs 9psi on this car is not straining it in the least.

 

Basically, I am at the breaking point. I won't bore you with the other warranty claims I had to deal with, but this really is the last straw. The warranty is ending, and so is my patience. Endless searching of forums, has not helped, and I joined to specifically ask for help here with this issue.

 

Solutions?

 

I have read about possibly the clutch line being the problem. Upgrading seemed to help some cars, but not others.

 

It also seems like the 2010s had the best luck with clutch pedal feel, and non-exploding clutches. So how common is a sticky clutch pedal on the 2010s exclusively?

 

I was disappointed to find out that the 2010s didn't have the clutch assist spring. I was hoping to yank that out, and be done with it.

 

It almost feels like the main return spring, on the clutch pedal assembly, is just not strong enough at high rpms to pull the clutch back fast enough.

 

I feel lucky not to have any grinding issues, but not being able to rev this car out, and shift just disappoints me, and my opinion of what I thought was Ford's flagship model is diminishing. How can they not even design something so simple as a manual hydraulic CLUTCH system? We aren't talking the latest twin paddle flapper design here, either!

 

I'm really interested in hearing what can be done.

Edited by ShelbyGT5HUN

Share this post


Link to post
Share on other sites

I really really like my 2010 GT500.

 

The full throttle power is just brutal, with 540rwhp, and is more than enough for me. Turn all the safety systems off, and throw the keys to some 20-something kid, and he would be wrapped around a pole before he even got out of 2nd gear! I have a lot of respect for a car that comes with this much HP, with a warranty, sort of...

 

I come from a life-long Japan/German car ownership, where you can stress stock engines and transmissions to two or more times the HP rating they came with stock, and still work flawlessly. This is my first domestic. Here, my GT500 is only pullied, and its giving me huge red flags to dump it before it becomes a money pit of repairs.

 

The Issue:

 

Normal shifting only. Not speed or no lift. Just shifting smoothly, but at high rpms.

 

Shifting at high rpms, between 4,500 and redline, the clutch will stick to the floor / lose its return force, just enough to almost lock you out of any upward gear changes. When shifting, it feels like you just might not get the next gear. This happens on the 1-2 shift, 2-3 shift, and 3-4 shift. Can't check the 4-5 shift, because I don't really want to be going that fast anyway.

 

I don't get any grinding of gears during the gear change, but when the rpms are high, it feels like I'm almost out of clutch fluid, and shifting becomes a guessing game. It feels to me through my left foot that there is too much "spinning force" or some kind of "suction", yes these non-engineering terms, created by the high rpms that is keeping things from separating between the clutch pressure plate and friction disk. The clutch pedal just becomes really mushy and almost non-functional at the 4,500 to redline area on the tach. At lower RPMs, and in traffic, the clutch pedal, and transmission function 100% fine.

 

I have 7 months on the powertrain warranty, and this car has been BABIED since day one. No powershifting, no drag racing. The fact that the warranty is ending, has motivated me to drive the car harder than I have in the past to see what could be wrong with it. In fact, this problem was hard to discover, and I have only just noticed it, because you really can't test this anywhere except on the highway.

 

You are doing well over 120+ to bang out all those gears changes. Even a full bore 2-3 shift at redline is around 80mph! I am taking it to the dealer for a check, but I really expect nothing from them. In fact I don't want them to test it due to the speeds involved, and the thought of a tech romping on the car does not sit well with me. It seems like this problem will just be brushed under the rug. However, I cannot own a car that can't be driven within factory power levels. Yes I have a pulley, but come on, 14psi vs 9psi on this car is not straining it in the least.

 

Basically, I am at the breaking point. I won't bore you with the other warranty claims I had to deal with, but this really is the last straw. The warranty is ending, and so is my patience. Endless searching of forums, has not helped, and I joined to specifically ask for help here with this issue.

 

Solutions?

 

I have read about possibly the clutch line being the problem. Upgrading seemed to help some cars, but not others.

 

It also seems like the 2010s had the best luck with clutch pedal feel, and non-exploding clutches. So how common is a sticky clutch pedal on the 2010s exclusively?

 

I was disappointed to find out that the 2010s didn't have the clutch assist spring. I was hoping to yank that out, and be done with it.

 

It almost feels like the main return spring, on the clutch pedal assembly, is just not strong enough at high rpms to pull the clutch back fast enough.

 

I feel lucky not to have any grinding issues, but not being able to rev this car out, and shift just disappoints me, and my opinion of what I thought was Ford's flagship model is diminishing. How can they not even design something so simple as a manual hydraulic CLUTCH system? We aren't talking the latest twin paddle flapper design here, either!

 

I'm really interested in hearing what can be done.

 

 

 

This is a strange one. I've never heard of anyone else having this problem. I have a 2010, take it to redline more than not. NEVER had that problem. I was getting the dreaded 1-2 grind but that was twice and I think it was driver error.

 

 

Phill

Share this post


Link to post
Share on other sites

It's definitely a heavy duty transmission that doesn't like to be flat shifted or shifted in a hurry. It's almost like complaining you can't flat shift a Mack Truck's transmission. Just not in the cards from the get go.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...