Jump to content
Sign in to follow this  
Cobrafreak

This dont look good!!

Recommended Posts

Hey guys, I need some opinions/info. I popped the hood the other day and  haven't driven it in a few weeks and then I noticed there was a dampness around the super charger snout. not really wet to where I could wet my fingers but damp enough to make a color difference. I cleaned it off yesterday and drove around the block a few times. I got the boost up a few times, came home and there was nothing to be found. I don't know if maybe the seal behind the pulley has a little leak but just not constant. Has anyone seen this before that could give me some ideas. If you guys do think I need to replace the seal can you tell me if it something I can do myself or is it hard to do. Back story of the car is that it is a 2010 with 60k miles. It does have the 2.6 pulley that the previous owner put on. I have had the car since January of this year and have maybe put on 500 miles.Thanks for your input.

small super.jpg

Edited by Cobrafreak
problem fixed please delete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...